Supported Android Devices

1. Compatibility Requirements
For Android devices, Filo’s requirements for compatibility are the following:
1. Android 4.4 or above
2. Bluetooth Low Energy 4.0 or above
If your device supports the above features there is a high probability that it will work with Filo. The list of compatible models with Filo increases everyday, thanks to the help of our users. For more information regarding a specific model that is not listed below please feel free to write us at support@filotrack.com.
2. What Android devices have been tested?
Our application is regularly tested with every update on the Android devices listed below to make sure that Filo works properly. Don’t worry if your device is not listed; if it has the minimum compatibility requirements listed in point 1 it is probable that Filo will work correctly and we will be able to offer you any technical support necessary.
Samsung: Galaxy S4 mini, Galaxy S5, Galaxy S6 Edge, Galaxy Grand Neoplus, Galaxy Note 3
HTC: One
OnePlus: One, X
LG: G3, Nexus 5 (O.S. >= 5.0.0)
Motorola: Nexus 6
Huawei: Ascend P7 (O.S. >= 5.0.0) , Ascend P8 (O.S. >= 5.0.0)
3. My smartphone is not listed among the tested devices, will Filo still work with my phone?
If your device is not listed above but it has the minimum compatibility requirements, ther is a high probability that it will work correctly with Filo. We are always available to provide technical support. For any doubts on your device do not hesitate to contact us at support@filotrack.com.
4. Does Filo work with tablets?
Yes, assuming they also comply with the compatibility requirements listed above.
For other devices, we cannot provide the same level of support for resolving any issues that arise.
5. Is Filo for Android different from Filo for iOS?
No, the Filo product is the same for both.
6. Do the iOS and Android apps have the same features?
Yes, the Android and iOS apps provide the same functionality and will be constantly updated to offer the same user experience for both Android and iOS users.
7. Why can’t I find the Android app in the Play Store?
The Filo app requires a minimum of Android v4.4 to run. If it does not show up in the Play Store, this usually means your device is running an older version of Android.